Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Corrected links that should have been relative instead of absolute.

Interested in the development of the cutting edge development of audio-only games? Really love to read change logs? Instructed by your UROP supervisor to read this page? If any of these match you, then you've come to the right place! The latest build of Click to Speak is still heavily in development and here are its known issues. It should be noted that while there are plenty of new features rolling in, some older, rather important features have taken a short hiatus in the transition.

...

Known Issues with Code that Really Should Already Work:

  • Calling up a New Game does not initialize a blank Node correctly so the game displays nothing and the Orphan Tab consequently crashes the editorStarting a game from scratch does not provide the proper names in the drop down box
  • The initial load and deleting are noticeably slow, will have to switch to selective updates
  • Advanced Breakpoints feature does not accommodate multiple lines / scrollbar doesn't show up (word wrapping issue)
  • Advanced Breakpoints feature does not enjoy multiple, overlapping breakpoints.Sometimes when
  • Advanced Breakpoints jump when clicked on, don't work when moved quickly, sometimes scroll offscreen.
  • Deleting will only move immediate children to the Orphan Tab. Anything nested won't be added (but will be removed from the screen). Use recursion!
  • If you collapse a high tier node sometimes there's extra space created below. This is from a nested Node having its includeInLayout attribute to true -- double check the boolean toggles it is feeling particularly moody, Delete won't quite work as predicted (sometimes one random Node will be left behind. I haven't figure out a pattern behind this) This could possible be from XML issues since the test files are handwritten.

Places for Refactoring:

  • There are two variables for each DialogueNode that are called _show and _visible. They do very different things but their names are ambiguous. Clear up this confusion!
  • Once the new architecture is firmly in place, rename DialogueNodeExp to DialogueNode and toss out the old version. That should clear up the two files' shared ambiguity.
  • refreshDialogueNodes in the DialogueNodeContainer should really be rewritten to do selective updates.