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Monitor / Plan / Analyze

• An integrated Performance Management process is the ultimate goal of our vision.  Using the different 
capabilities associated with BI, and tying them all together to be fully integrated, allows the PM cycle 
to be repeated as often as the business demands it.  This is a far cry from what most companies are 
able to do today, and reveals itself as a competitive advantage through optimization of the operational 
efficiency.
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Integrated Offering
• The Microsoft product that plays the primary role here is SQL Server 2005.  Besides the relational engine, SQL 

Server provides three key components that support the three key technical activities, or verbs, of BI.  Integration 
Services is the ETL tool.  It lets you pull together data from multiple sources and create, or synthesize, new 
information.   It’s high-performance, with a very rich feature set.  Analysis Services let’s you express, and 
calculate, business logic.  You want to enrich your data with consistent, centralized calculations that express the 
way the company thinks about its data, and its business.  Reporting Services addresses distribution of data and 
information, to end-users, via reports.  These can be ad-hoc reports built using Report Builder.  Or they may be 
production reports delivered, on a schedule, through email or your corporate portal, typically SharePoint.

• Once you believe in, trust, your data, the next step is to address and support the insights your employees derive 
from that data.  Microsoft Office and the Office Server System, via Excel and SharePoint, address the need to 
‘trust your insights’.    We have a lot of end-user tools.  But just letting your users loose with an OLAP tool and a 
server full of cubes will not lead to consistent, quality insights.  First, you’d be making your users find the data.  
And who’s to say two people trying to explore the same opportunity will find the same supporting data.  Yes, we 
want creativity, but we don’t want one department working off this year’s numbers while another only finds last 
year’s.  The related problem is that users often find too much data.  We don’t really need everyone accessing 
every piece of data in the company.  The other issue companies face at this middle level is a daunting investment 
in training users on these tools.  There is a staggering amount of shelf-ware in the OLAP tools market.  In the 
Microsoft stack, we use SharePoint, in particular the Business Data Catalog, to help users find relevant, fresh data.  
Excel is the tool that most end-users already know.  In Office 2007 we’ve built a tight link between Excel and SQL 
Server Analysis Services, you can see that in the diagram, that makes analysis of centrally calculated and managed 
data a first-hand experience.

• Now, beyond trusting your data, and trusting the insights of your employees, you need to address the quality of 
corporate decisions.  If you just deploy the first two layers of the Microsoft BI stack, you will have enabled 
individuals in your company to gain better insights and hopefully make better decisions.  That’s BI at the personal 
level.  What makes BI corporate?  What let’s you ‘trust your decisions’?  We’re adding a new layer to the stack 
that addresses Performance Management.  We want to make BI more complete, more corporate and more 
accountable.  By more complete, we mean more subject areas and the whole BI process.  We need to break these 
down separately.  Most users, when they do personal BI, generally consume one, maybe two data sources, but 
rarely multiple subject areas.  So we might analyze the sales of our store.  Maybe we’re focusing on how to 
understand our revenues based on time of day.  Imagine being the district manager and doing this across your 
stores.  That’s interesting.  But you have to look at other factors.  If one of those stores pays outrageous rent, the 
right answer might be to shut that store down.  Or move it.  All the sales analysis in the world is wasted until you 
discover and address the real performance issue.  By BI process, I go back to the ‘five questions’ of BI. These are:
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New features 

• Microsoft Business Scorecard manager launched the first wave in Microsoft’s scorecard offering. With 
the release of PerformancePoint Server 2007 Microsoft takes this to an enhanced new level, offering 
greater flexibility and extended capabilities.
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Components

• Monitoring Server is a computer or group of computers that host Monitoring System Database and 
Monitoring Server Web Service. Monitoring System Database is a database that stores the Monitoring 
Server metadata, which consists of user permissions and settings for dashboard elements. Monitoring 
Server Web Service is a collection of application programming interfaces (APIs) that provide the core 
functionality of Monitoring Server, connecting Dashboard Designer to the Monitoring Server database, 
Dashboard Viewer for SharePoint Services, and data sources.
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Step One: Create a workspace

• First you create a workspace, which is a type of file that stores information, called elements, on which 
scorecards are based. These elements are key performance indicators (KPIs), scorecards, data sources, 
reports and indicators. After you create a workspace you can create multiple scorecard elements 
within that workspace. 

Step Two: Create elements

• Next you create the elements for your workspace (KPIs, scorecards, data sources, reports, indicators 
and dashboards). You can create them in any order, but some dependencies apply. For example, 
except for fixed  data KPIs, you will need to create the Data Source first. 

Step Three: Configure Elements

• Next you configure elements in the Dashboard Designer by adding data sources and indicators to KPI’s. 

Step Four: Configure scorecard

• Design your scorecard by adding KPI’s and arranging your hierarchy

Step Five: Configure dashboard

• Design your dashboard by adding scorecards and linking reports

Step Six: Deploy dashboard

• Finally, you deploy your dashboards so users can interact with it. 
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Dashboard
• A related group of interactive scorecard and report views that are organized together in a single 

SharePoint site. Dashboard elements may share common filters that control the data displayed within 
the elements

KPI
• An explicit and measurable value taken directly from a data source. KPIs are used to measure 

performance in a specific area, such as revenue per customer.

• The value of the KPI is determined by the method used to define the element entry

Scorecards
• .A collection of key performance indicators (KPIs) and objectives, possibly arranged hierarchically. 

Scorecards are used to measure multiple facets of organization performance.

Data Sources
• A source of business data used by Dashboard Designer to create scorecards. Data sources include 

online analytical processing (OLAP) cubes, relational databases, or any other Open Database 
Connectivity (ODBC) or ADOMD.NET data source. 

Indicators
• A graphical status symbol that represents where the value of a key performance indicator (KPI) is in 

relation to the target value. Indicators are represented by using status images and colors (indicator 
band colors). Users that configure the indicator designate a color for each indicator band. 

Reports
• A set of one or multiple read-only PerformancePoint Server matrixes that are created by using 

PerformancePoint Add-in for Excel. These matrixes are made up of rows, columns, and optionally, 
data filters, and other data or strings that are displayed in an Excel workbook. A report can be 
created by using the PerformancePoint Add-in for Excel authoring pane or the Create a Report 
wizard

9
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PPS Demo Dashboard

• PerformancePoint Server Monitoring ships with a number of predefined dashboards. In this 
demonstration we will look at the Demo Dashboard and explore the new features and capabilities.
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Definition

• The Dashboard Designer both consumes and saves element information in .bswx files. These offline 
XML files contain the metadata that defines the scorecards and their elements.

• Workspaces can be stored in any location on either a local file system or a network share. When you 
design a company’s business intelligence (BI), you should standardize development strategy file 
storage.

• When you open Dashboard Designer, a vertical bar separates the workspace into two panes. The pane 
on the left is the Workspace Browser. After you open a workspace in Dashboard Designer, you use the 
Workspace Browser to create new scorecard elements or to quickly access existing scorecard elements 
so that you can review or modify them. As you create scorecard elements, they are added to the list of 
elements in the Workspace Browser. The pane on the right is where scorecards and their related 
elements are created and reviewed. 

• When you select an element or folder in the Workspace Browser, information about that element or 
folder appears in the right pane. For example, if you select the KPI folder, a list of actions appears in 
the pane to the right.  If you select a specific KPI, details about the KPI appear.

Benefits

• You can create scorecards and scorecard elements offline and save the data you create locally. 

• You can migrate to and from Microsoft Dashboard Designer and another environment, for example, 
from a test to a production environment.

• You can send workspace files to coworkers for feedback before publishing the scorecards and 
scorecard elements in these workspace files to the Monitoring Server.

11
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Publishing

• After you create one or more KPIs, scorecards, data sources, indicators or reports, you can publish 
these elements to the PerformancePoint Monitoring Server. In doing so, the elements you created 
from within your local workspace are made available to all users with access to the server and who are 
assigned the permissions to view scorecards on the server.

Synchronizing

• A pencil icon on the element icon in the Workspace Browser indicates that the element has not yet 
been published to the server. You can publish elements individually or you can publish all unpublished 
elements in an open workspace simultaneously. 

• If you are publishing scorecard elements that have already been deployed to your SharePoint site, 
updates to these scorecard elements appear on the site immediately after you publish them. 

Note

• Publishing to the server does not automatically save a local copy of the updates made in your 
workspace. Saving changes locally and publishing to the server are separate actions. 
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Delete

• You use the Delete command to delete an element (KPI, scorecard, data source, indicator or report) 
from the Monitoring Server or the Workspace. 

To delete an element 

1. In the Workspace Browser, click the type of element you wish to delete.

2. In the Workspace, click the Sever or Workspace tab. 

3. In the Workspace, select the element you wish to delete

4. In the Home tab of the ribbon, in the Editing group, click Delete. 

5. A message asking you to confirm the deletion appears. Click Yes to confirm the deletion.

To restore an element

1. If you have deleted an element from the server, but not from the workspace, you can re-publish that 
element to the server. 

2. If you have deleted an element from the workspace, but not from the server, you can select it in the 
server tab, and In the Home tab of the ribbon, in the Editing group, click Open Item.

3. If you have deleted an element form both the server and the workspace, if you have a backup of the 
SQL Server-based database you can restore the database to another server and then pull the element 
down to the local workspace and publish to the production server.
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Compare

• Each time a scorecard element is published to the PerformancePoint Monitoring Server, a new version 
of the element is created on the server. Use the Compare command to view the differences between a 
scorecard element in your local workspace and the latest published version of the element on the 
server. 

To compare an element in a workspace and on the server

1. In the Workspace Browser, click the element that you want to compare against the corresponding 
version on the server, and then in the Changes group, in the Home tab, choose Compare.

2. Click OK to close the dialog box.

Note

• If there is a difference between the local workspace version and the published version of the element, 
the Compare with Server dialog box appears and displays the difference.
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Validate

• When you create or update a scorecard in PerformancePoint Business Scorecard Builder or create or 
update an element in the scorecard, you can check whether all of the required values for the 
scorecard or the scorecard element exist and have been published to the Monitoring Server. For 
example, you can validate a key performance indicator (KPI) to make sure that the data sources and 
indicators associated with the KPI have been published to the server. You also can validate a scorecard 
to check whether all of the KPIs in the scorecard and their corresponding data sources and indicators 
have been published to the server. If there is an error in a scorecard when you view the scorecard on a 
SharePoint site, use the validate command on the scorecard in Business Scorecard Builder to view 
issues related to the scorecard. 

To Validate an element

1. In Workspace Browser, click the element that you want to validate, and then in the Home tab, in the 
Changes group, click Validate.

2. If all of the elements that are associated with the scorecard element exist on the server, a 
confirmation message is displayed to that effect.

3. If the scorecard element or any of its associated elements do not exist on the PerformancePoint 
Monitoring Server or if you do not have the required permissions to access the element, the 
Validations dialog box opens. Specific information about what is missing from the server is displayed in 
the dialog box. 

4. Click OK to close the message box or dialog box.
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History

• The history of a scorecard element shows the user who edited the element, the date and time of the 
edit, and details about the type of edit. For example, if a user was added to the Reader role, the 
domain and alias of this user will appear in the history.

To view the history of an element

1. In the Workspace Browser, right-click the element whose history you want to view, and then select 
View History. The History table appears.

2. Review the history for the scorecard element, and then click OK to close the table.
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Revert

• Each time a scorecard element is published to the Monitoring Server, a new version of the published 
item is created on the server. Use the Revert command to revert to a previous version of a scorecard 
element from within the open workspace.

To revert to a different version of a scorecard or scorecard element

1. In the Workspace Browser, click the appropriate scorecard, KPI, indicator or report, and then click 
Revert. The History dialog box appears. 

2. In the History list, select the version that you want to revert to.

3. Click OK. The version you choose to revert to will appear in the open workspace.
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Bulk Edit

• Often businesses have a performance target change that affects more than one KPI. Dashboard 
Designer provides the ability for you to update multiple KPIs one pass by using the Bulk Editing 
dialog. You can only edit KPIs that are in your workspace, not on the server.

Important: 

• Bulk editing enables editing of multiple objects at once. Once changes have been made, they cannot 
be undone.

To Bulk Edit multiple KPIs

1. On the workspace browser pane, click on the top KPI folder.

2. Click the Workspace tab in the center pane.

3. Select as many KPIs as needed to edit (SHIFT+Click)

4. Click the Edit tab on the ribbon, and then click Bulk Edit.

5. Type the description of the changes you are making in the box provided.

6. Enter the name of the person that owns this action.

7. Create or select a display folder under which to save these newly edited KPIs (optional).

8. Click Next. 

9. Make the necessary edits. Click Finish.

10. When the confirmation screen displays, click Close.
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Data Source Overview

• PerformancePoint Server allows you to connect to many types of data sources to take advantage of 
the often complex and varied data systems where companies store their data.
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To Set General Properties for a Data Source

1. Click the Properties tab to adjust any general properties. 

2. In the Name text box (required), keep or edit the name of the data source.

3. In the Description text box (optional), enter a description that defines this data source.

4. In the Person Responsible text box (required), enter the name of the person creating this data source.

5. In the Display Folder text box (optional), enter the name of the folder which contains this data source.

6. If you want to add one or more custom properties, click the New Property button. Select the property 
type you want to add and click OK. Enter the Name, Value and Description of the property. (optional)

7. To add a user with permission to read or edit this data source, click the New Permission button.

8. In the new row that's created, add the new user's name in the format DOMAIN\alias, and then choose 
a permission of either Editor or Reader.

Module 3: Elements
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Analysis Server Data Sources
• Create a data source connecting to data from SQL Server Analysis Services. First you set up the basic 

structure for the data source and configure it, and then you can adjust the properties and define Time 
Intelligence (optional).

To set up the structure for the Analysis Services data source 
1. Click the Create tab in the Ribbon, and then click Data Source.

2. In the Select a Data Source Template dialog box, click Multidimensional and then select the Analysis 
Services icon. Click OK. 

3. Type the data source name in the Name text box and specify the folder display location and user 
access options. You can create or select a new folder location by clicking Select Display Folder. The 
folder you specify will appear in the Workspace Browser pane, which is useful for organizing multiple 
reports.

4. Click Finish. This will set up the basic structure for your data source and display a confirmation screen. 
On the confirmation screen, click Close. Your data source is now available for editing in the workspace.

To configure the data source connection
1. Click the Editor tab in the workspace, and establish the connection settings by typing the complete 

path to the Server.

2. The Database box will be automatically populated with values based on the server designated. Select a 
Database name.

3. In Roles, type in an informational role description (this is optional)

4. OR: Click Use the following connection to enter a connection string to the server and database to 
where you want to connect.

5. Select the specific cube you want to use as the data source in the database.

6. Adjust the refresh rate under Cache settings (this is optional).

7. Click Test Connection to confirm the connection is properly configured.

8. Click the Home tab in the Ribbon, and then click Publish All.
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Multidimensional Time Intelligence
• Time Intelligence (TI) is a collection of built-in enhancements of Monitoring Server. TI features enable you to create 

reports that use relative levels for time members, such as "the most recent 6 months". Monitoring Server recalculates 
the report automatically as the current date changes. 

• TI features enable you to map time member levels for each separate data source into a unified calendar. The unified 
calendar and its associated calendar hierarchies are called the Master Time Dimension. In this manner, TI enables you to 
combine data from multiple and different data sources. For example, you can create a report that uses revenue data 
from a multidimensional data source and then combine that information with budget data from an Excel spreadsheet.

• You can map hierarchies from several different multidimensional cubes to the Monitoring Server Master Time 
Dimension. However, you can map only one time hierarchy per data source. To map more than one time hierarchy from 
a single cube, you must create separate data sources for each dimension you want to map.

Steps To Set Time Intelligence Settings on Multidimensional Sources
1. In the Workspace Browser pane, expand Data Sources. Then double-click the name of the multidimensional data source 

that you want to configure for TI.

2. The Workspace pane displays tabbed screens that enable you to edit the data source properties or configure settings 
for TI.

3. In center Workspace pane, click the Time tab.

4. In the Reference Data Mapping pane, select the source time dimension from the drop-down list that you want to map 
to the Master Time Dimension.

5. In the Reference Member section, do the following:
1. Click Browse to select a Member. The Member Selection dialog box opens and displays the members of the 

time dimension you selected in step 3. Monitoring Server uses the Reference Member as the basis for time 
operations. Monitoring Server calculates all other dates and time periods that are used in the dashboard relative 
to this reference point.

2. From the Hierarchy level drop-down list, enter the hierarchy level that corresponds to the Member that you 
selected in step 4-a. This value must be one of the following: Year, Semester, Quarter, Month, Week, Day, Hour, 
Minute, or Second.

6. Enter a Reference Date that represents the time period specified by the Reference Member that you specified. 
Monitoring Server uses the Reference Date to identify the relationship of the Reference Member to the Gregorian 
calendar.

7. In the Time Aggregation grid, select the time period level, such as Year, Month, Week, or Day, at which you want 
Monitoring Server to calculate aggregation for the indicated member.

8. Notice that only members of time dimensions that have been mapped to the Master Time Dimension are available for 
aggregation settings. Monitoring Server calculates aggregations to the same level of detail that is used for the 
Reference Member that you specified in step 4.
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SharePoint List
• Create a data source connection to a Window SharePoint Services 3.0 list or Microsoft Office 

SharePoint Server 2007 list. First you set up the basic structure for the data source and configure it, 
and then you can adjust the properties and define Time Intelligence (optional).

To create a SharePoint List data source
1. Click the Create tab, and then click Data Source.

2. In the Select a Data Source Template dialog box, click Tabular List and then click the SharePoint Lists 
icon. Click OK.

3. In the Name text box, type the data source name.

4. (Optional) Click the Select Display Folder button, and then enter a new folder location or click Browse… 
to select a location. 

5. The folder you specify will appear in the Workspace Browser pane, which is useful for organizing 
multiple reports.

6. (Optional) Check Grant Read permission to all users who are authenticated to PerformancePoint 
Monitoring Server to enable users to read the data and settings in the data source.

7. Click Finish. 

8. This will set up Monitoring Server object for your data source, and then display a confirmation screen. 

9. On the confirmation screen, click Close. Your data source is now available for editing in the workspace.

To configure a connection to the SharePoint data source
1. Click the Editor tab in the workspace, and type the URL to the SharePoint site in the text box.

2. From the SharePoint Site List, select All Lists.

3. Select the specific data list you want to use as the data source from the drop-down list.

4. In the Cache Settings section, in the Interval text box, enter the refresh rate (in minutes) for the cache. 
Data from this data source will be updated at this interval.

5. Click Test Connection to confirm the connection is correctly configured.

6. Click the Home tab, and then click Publish All.
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SQL Server Table
• You can use a table from a SQL Server database as a data source for your Dashboard elements. First you set up the 

basic structure for the data source and configure it, and then you can adjust the properties and define Time 
Intelligence (optional).

To set up a SQL Server Table data source
1. Click the Create tab, and then click Data Source.

2. In the Select a Data Source Template dialog box, click Tabular List and then click the SQL Server Table icon. Click 
OK.

3. In the Name text box, type the data source name.

4. (Optional) Click the Select Display Folder button, and then enter a new folder location, or click Browse to select a 
location.

5. The folder that you specify will appear in the Workspace Browser pane, which is useful for organizing multiple 
reports.

6. (Optional) Select the Grant Read permission to all authenticated users check box to enable users to read the data 
and settings in the data source.

7. Click Finish. 

8. This sets up the basic structure for your data source and displays a confirmation screen. 

9. On the confirmation screen, click Close. Your data source is now available for editing in the workspace.

To configure a connection to a SQL Server Table data source
1. Click the Editor tab in the workspace to establish the connection settings. Do this by selecting either Use Standard 

Connection or Use the following connection.
a) If you select Use Standard Connection, type the name of the server where the SQL Server data resides and 

then select the database.
b) If you select Use the following connection, type a connection string to the server and then select the 

table. 

2. From the Tables drop-down list, select the tables that you want to include in your data source.

3. In the Cache Settings section, in the Interval text box, enter the refresh rate (in minutes) for the cache. Data from 
this data source will be updated at this interval.

4. Click Test Connection to confirm that the connection is correctly configured.

5. When you finish configuring the data source, click the Home tab, and then click Publish All.
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Excel 2007
• When you create a data source using an Excel data source, Monitoring Server imports and saves the 

data to the Monitoring Server database. You can set a column as a key, choose to aggregate data in a 
number of ways and even choose to ignore a column. 

• Use an Excel 2007 workbook for a data source when you do not want to share the Excel data with 
users via Excel Services. The Excel Workbook will be stored and hosted within the Dashboard Designer 
database, and can only be edited and updated from within Dashboard Designer.

To Create an Excel Workbook Data Source
1. Click the Create tab, and then click Data Source.

2. In the Select a Data Source Template wizard, click Tabular List, click the Import from Excel 2007 
Workbook icon, and then click OK.

3. In the Name text box, type the data source name.

4. (Optional) Click the Select Display Folder button, and then enter a new folder location or click Browse… 
to select a location. 

5. The folder you specify will appear in the Workspace Browser pane, which is useful for organizing 
multiple reports.

6. (Optional) Check Grant Read permission to all users who are authenticated to PerformancePoint 
Monitoring Server to enable users to read the data and settings in the data source.

7. When finished, click Finish. The name of the data source now appears in the Workspace Browser 
under Data Sources. 

8. Add data to the data source. You can either populate a blank worksheet or open a workbook that you 
have already created.

a) To create data in a new workbook, click the Editor or View tab, and then click Edit. Office Excel 
will open a blank worksheet. 

b) To import data from an existing workbook, click the Editor tab, and then click Import. Browse to 
the source file. Only Office Excel 2007 worksheets can be imported into Monitoring Server. 

9. When you are ready to save the data, click Accept changes in the Edit data in Excel dialog box. The 
data will be imported into Monitoring Server for use as a data source.
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Excel Services
• Monitoring Server enables you to create a data source using Excel Services, which is part of Microsoft Office 

SharePoint Server 2007. Excel Services extends the capabilities of Microsoft Office Excel 2007 by enabling broad 
sharing of spreadsheets, and improved manageability and security.

• When you use Excel services as a data source, you can publish an Office Excel Workbook to SharePoint. You can also 
refer to Named Objects in the workbook, such as Table, Named Range, and Pivot Table. You can update the workbook 
within Excel and any changes to the data will automatically be reflected in the data source.

To Create an Excel Services Data Source
1. Click the Create tab, and then click Data Source.

2. In the Select a Data Source Template wizard, click Tabular List and then click the Excel Services icon. Click OK.

3. In the Name text box, type the data source name.
4. (Optional) Click the Select Display Folder button, and then enter a new folder location or click Browse to select a 

location. 

5. The folder you specify will appear in the Workspace Browser pane, which is useful for organizing multiple reports.

6. (Optional) Select the Grant Read permission to all users who are authenticated to PerformancePoint Monitoring 
Server check box to enable users to read the data and settings in the data source.

7. Click Finish. 

8. This will set up the basic structure for your data source and display a confirmation screen. 

9. On the confirmation page, click Close. Your data source is now available for editing in the workspace.

To configure a connection to the Excel Services data source
1. Click the Editor tab in the workspace, in the SharePoint Site text box, type the full path of the SharePoint site where 

you have Excel Services installed.

2. Select the Document Library where the workbook is located. This field will be automatically populated based on the 
available libraries on the SharePoint site that you entered. 

3. From the Excel Workbook list, select the file that you want to use. To view the workbook in the browser, click View.

4. In the Item Name text box, type an item name. An Item is a feature of Excel Services 2007 that enables you to isolate a 
subset of data that cannot be easily grouped in other ways.

5. In the Workbook Parameters section, enter parameters for the workbook. An Excel Services parameter enables you to 
specify cells that can be modified when you view the workbook. Within Excel Services determine which parameters 
you want to make available to the user.

6. In the Cache Settings section, in the Interval text box, enter the refresh rate (in minutes) for the cache. Data from this 
data source will be updated at this interval.

7. Click Test Connection to confirm that the connection is correctly configured.

8. Click the Home tab, and then click Publish All.
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To Set Aggregation Levels on Fact Columns

1. On the workspace browser pane, double-click on the Excel data source you want to edit.

2. In the workspace, click the View tab.

3. Select a column (typically those with numeric values) that you want to set an aggregation level on.

4. In the Details pane, verify that the column type is set to Fact.

5. From the Aggregation list, select the level at which you want to aggregate the data in that column. 
. The default setting is Sum. Other options: Average, Count, Dimension Minimum, None, Statistical 
Standard Deviation, Sum, Statistical Variance and First Occurrence.
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Time Intelligence – Tabular Data Sources

• Time intelligence is the definition of the current time period. In Dashboard Designer, customize the 
time period levels when you create your tabular data source.

Setting Time Period Levels for Tabular Data Sources

1. On the Workspace Browser pane, expand Data Sources. Then, double-click the name of the tabular 
data source that you want to configure for TI.

2. The Workspace pane displays tabbed screens that enable you to modify the data source properties, or 
configure settings for TI.

3. In the center Workspace pane, click the Time tab.

4. Select the Master check box that corresponds to the Time Dimension that you want Monitoring 
Server to use as the Master Time Dimension for TI.

5. Notice that the Time Dimension column lists names of data source columns that have a Column Type:
property of Time Dimension. 

6. In the Time Period Levels: pane, select the time periods that you want TI to use for aggregation, such 
as Year, Month, Week, Day, and so on.

7. From the Fiscal Start Month drop-down list, select the month that you want to use as the start month 
of your fiscal calendar.
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ODBC Connections
• Dashboard Designer provides the ability for you to use an Excel ODBC connection to connect to external Excel 

Workbook files located on the PerformancePoint Server. This solution allows customers who do not have 
SharePoint the ability to update their Excel files outside of Dashboard Designer. For this usage, Dashboard 
Designer supports Excel 97 through Excel 2007.

Steps to create an ODBC data source
1. Click the Create tab on the Ribbon, and then click Data Source.

2. In the Select a Data Source Template wizard, click Standard Queries, click the ODBC icon, and then click OK.

3. Type the data source name in the Name text box (required). 

4. To grant Read permission to all authenticated users, select the Grant Read permission to all authenticated users 
check box.

5. When you finish, click Finish. The name of the data source now appears in the Workspace Browser under Data 
Sources. 

6. In the Connection Settings section, in the Connection String box, type the connection string for the ODBC 
connection.

7. Example: Driver={SQL Server};Server=ComputerName;Database=AdventureWorksDW

8. In the Cache Settings section, in the Interval box, enter the refresh rate (in minutes) for the cache. Data from this 
data source will be updated at this interval.

9. Click Test Connection to confirm that the connection is correctly configured.

10. Click the Properties tab to adjust any general properties. In the Name text box, keep or change the name of the 
data source.

11. In the Description text box (this is optional), enter a description that defines this data source.

12. In the Owner text box, enter the name of the person who created or owns this data source.

13. In the Display Folder text box (this is optional), enter the name of the folder that contains this data source.

14. If you want to add one or more custom properties, click the New Property button. Select the property type that 
you want to add and then click OK. Enter the Name, Value, and Description of the property.

15. To add a user who has permission to read or edit this data source, click the New Permission button.

16. In the new row that is created, add the new user's name in the format DOMAIN\alias, and then select a 
permission of either Editor or Reader.

17. Click the Home tab, and then click Publish All.

Module 3: Elements

Microsoft Confidential Page: 14



ODBC Time Intelligence

• Time intelligence is the definition of the current time period. In Dashboard Designer, customize the 
time period levels when you create your ODBC data source.

Steps to Set Time Intelligence on ODBC Data Sources

1. On the Workspace Browser pane, double-click the data source that you want to change.

2. In the center Workspace pane, click the Time tab.

3. Select the time period levels (Year, Semester, Quarter, Month, Week, Day) in the Workspace Browser 
pane, double-click the data source that you want to change.

4. In the center Workspace pane, click the Time tab.

5. Select the time period level at which you want to roll-up or group your data. Options include by Year, 
Semester, Quarter, Month, Week, and hour, minute and second.

6. Select the starting month of your fiscal calendar in the Fiscal Start Month box.
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Working with Scorecards

• The Scorecard workspace appears when either Scorecards is highlighted in the Workspace Browser 
pane or an individual Scorecard has been selected. This workspace, which appears as the largest pane 
in the center of the Dashboard Designer interface, allows you to edit Scorecards and view details, such 
as related key performance indicators (KPIs), Data Sources, and Indicators. It also allows you to adjust 
properties, such as the Scorecard name, folder location, and user permissions.

• Two different sets of tabs can be visible in the Scorecard workspace, depending on what is selected in 
the Workspace Browser. For example, the Server and Workspace tabs are visible only when Scorecards 
is selected in the Workspace Browser pane and no particular Scorecard has been selected. The Editor 
and Properties tabs are visible only when a Scorecard has been selected for editing, which is done by 
double-clicking on a Scorecard name in either the Server or Workspace
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Balanced Scorecards:
• According to David Norton, the father of the Balanced Scorecard, “a balanced scorecard is a system of linked objectives, 

measures, targets and initiatives which collectively describe the strategy of an organization and how that strategy can be 
achieved.”

• The term “balanced” refers to the fact that companies must take a balanced approach to managing their business. All too 
often, businesses focus on financial metrics – Net Income, Revenue, Earnings per share. Financial metrics are great and 
easy to understand, the only problem with them is that they tend to be lag indicators. They are great at telling you how 
your business did but how many of us drive our cars looking in the rearview mirror?

FOSH
• Balanced scorecards measure progress from four recommended perspectives

Financial
• Financial metrics portray the economic results of the previous business decisions and actions. Financial metrics tend to 

lag the actions, and therefore are not necessarily reflecting the business as it is run today. They are often the ultimate 
determinant of whether the strategy is successful or not.

• A typical question related to the financial perspective is: To succeed, how should we appear to our shareholders?

Operational Excellence, also called Internal
• The operational perspective reflects the business processes that support the strategy. They may include processes 

related to financial collections, safety in manufacturing, or product development. The common thread running through 
these processes is that they are the ones that the business must excel at to succeed.

Sales, referring to the Customer
• The sales perspective focuses on how the customers perceive the business. Because customer perception is affected by a 

number of business activities, this perspective tends to be a good general performance indicator. For example, it is 
affected by such things a product quality, delivery reliability, help desk responsiveness and competency, and the manner 
in which the sales force treats them. If your customers perceive your performance negatively, you may need to make 
adjustments in other perspectives.

Human Resources, also called Learning and Growth
• The human resources perspective encompasses the infrastructure of the company, mainly the employees, systems and 

organizational procedures. Metrics in this perspective highlight the success of businesses maintaining employee skills, 
improving work satisfaction, updating the systems they use to perform their jobs, and ensuring that the organizational 
procedures facilitate success.
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To create an Analysis Server scorecard

1. On the Create tab of the Ribbon, click Scorecard.

2. In the Template Wizard dialog box, click Microsoft, and then click the Analysis Services template. Click OK.

3. Specify the scorecard name and the folder location for the default display. The default display folder is an optional 
feature that can help you organize your scorecards in the Workspace Browser.

– If desired, select the Grant Read permission to all authenticated users on the PerformancePoint Scorecard 
server check box.

4. Select the data source from either the Workspace or Server tab. Click Next. Note: Click Refresh to make sure that you 
are viewing the current list of defined data sources.

5. Select either Create KPIs from Analysis Services Measures or Import SQL Server Analysis Services KPIs as the source 
of your KPIs. Click Next.

6. Use one of the following procedures.

7. Add new KPIs by clicking Add KPI for every KPI that you want to add. Adjust the settings for each KPI as needed OR 
Click Select KPI to select a pre-defined KPI. Select the desired KPI from either the Workspace or Server tab and then 
click OK. Repeat this for every additional KPI that you want to add.

8. Note: Click Refresh to make sure that you are viewing the current list of defined data sources.

9. Click Next.

10. Select the Add measure filters check box if you want to add measure filters for the Scorecard KPIs.

11. Click Select Dimension. Select the dimension desired, and then click OK.

12. Click Select Member to select the specific members for the Actual measure filter. Click OK.

13. Click Select Member to select the specific members for the Target measure filter. Click OK.

14. Click Next.

15. Select the Set members for the columns check box if you want to create a matrix-style view for your scorecard.

16. Click Select Dimension. Select the dimension for the columns (typically time), and then click OK.

17. Click Select Member. Select the specific members to be displayed on the columns. Click OK and then click Finish.

18. When you see the confirmation screen, click Close.

19. From the Details pane, drag any additional items onto your workspace in the center pane (optional).

20. From the Home tab, click Publish All.
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To create a Fixed Values scorecard

1. On the Create tab of the Ribbon, click Scorecard.

2. In the Create New Fixed Values Scorecard dialog box, click Fixed Values, and then click OK.

3. Specify the scorecard name and default display folder location. Click Next:

a) The default display folder is an optional feature that can help you organize your scorecards in 
the Workspace Browser.

b) If desired, select the Grant Read permission to all authenticated users on the 
PerformancePoint Scorecard server check box.

4. Add new key performance indicators (KPIs) by clicking New KPI. 

5. To edit or create a new name for each KPI, click on the value in the KPI name box and start to type. 

6. Select the desired band type.

7. Enter your desired Actual and Target values.

8. Repeat for each additional KPI you wish to add. When complete, click Finish and then Close.

9. Your completed scorecard appears in the Workspace. If you wish to include additional items to your 
scorecard, drag and drop from the Details pane onto the center workspace.

10. From the Home tab, click Publish All.
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Blank Scorecards

• Use a blank scorecard to design a scorecard that does not have predefined content or data mappings. 
Use a drag-and-drop operation to move elements from the Details pane to the center workspace. 

Note: You must define your KPIs before you build your scorecard. 

To create a blank scorecard

1. Click the Create tab, and then click Scorecard.

2. In the Select a Scorecard Template dialog box, click Standard and then click Blank Scorecard. Click OK.

3. Specify the scorecard name and default display folder location. The default display folder is an optional 
feature that can help you organize your scorecards in the Workspace Browser.

4. If you want to, select the Grant Read permission to all authenticated users check box.

5. Click Finish.

6. From the Details pane, drag the elements onto the center Workspace and design your scorecard. 

7. On the Home tab, click Publish All.
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To create an Excel 2007 scorecard 

1. On the Create tab of the Ribbon, click Scorecard.

2. In the Select a Scorecard Template dialog box, click Tabular and then Excel 2007. Click OK.

3. Specify the scorecard name and default display folder location. The default display folder is an optional feature 
that can help you organize your scorecards in the Workspace Browser.

– If desired, select the Grant Read permission to all authenticated users on the PerformancePoint 
Scorecard server check box.

4. Click Next.

5. Select the data source from either the Workspace or Server tab. Click Next. Note: Click Refresh to ensure you are 
viewing the current list of defined data sources. 

6. Add new key performance indicators (KPIs) by clicking Add KPI for every KPI you wish to add. Adjust the settings 
for each KPI as necessary OR

7. Click Select KPI to select a pre-defined KPI from either the Workspace or Server tab. Click OK. Repeat this step for 
every additional pre-defined KPI you want to add. Note: Click Refresh to ensure you are viewing the current list of 
defined data sources. 

8. Click Next.

9. Select the Add measure filters checkbox if you want to add measure filters for the Scorecard KPIs.

10. Click Select Dimension. Select the dimension for the measures filter, and then click OK.

11. Click Select Member to select the specific members for the Actual measure filter. Click OK.

12. Click Select Member to select the specific members for the Target measure filter. Click OK. 

13. Click Next.

14. Select the Set members for the columns checkbox if you want to create a matrix style view for your scorecard.

15. Click Select Dimension. Select the dimension for the columns (typically time), and then click OK.

16. Click Select Member. Select the specific members to be displayed on the columns. Click OK and then click Finish.

17. When you see the confirmation screen, click Close. Your scorecard appears in the center Workspace. 

18. From the Details pane, drag and drop additional elements to the center pane (optional). 

19. From the Home tab, click Publish All. 
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To Create an Excel Services Scorecard
1. On the Create tab of the Ribbon, click Scorecard.

2. In the Template Wizard dialog box, click Tabular and then the Excel Services template. Click OK.

3. Specify the scorecard name and default display folder location. The default display folder is an optional 
feature that can help you organize your scorecards in the Workspace Browser.

– If desired, select the Grant Read permission to all authenticated users on the 
PerformancePoint Scorecard server check box.

4. Select the data source from either the Workspace or Server tab. Click Next. Note: Click Refresh to 
ensure you are viewing the current list of defined data sources. 

5. Add new key performance indicators (KPIs) by clicking Add KPI for every KPI you wish to add. Adjust 
the settings for each KPI as needed OR

6. Click Select KPI to select a pre-defined KPI from either the Workspace or Server tab. Click OK. Repeat 
this step for each additional pre-defined KPI you want to add. Click Refresh to ensure you are viewing 
the current list of defined data sources. 

7. Click Next.

8. Select the Add measure filters checkbox if you want to add measure filters for the Scorecard KPIs.

9. Click Select Dimension. Select the dimension desired, and then click OK.

10. Click Select Member to select the specific members for the Actual measure filter. Click OK.

11. Click Select Member to select the specific members for the Target measure filter. Click OK. 

12. Click Next.

13. Select the Set members for the columns checkbox to create a matrix style view for your scorecard.

14. Click Select Dimension. Select the dimension for the columns (typically time), and then click OK.

15. Click Select Member. Select the specific members to be displayed on the columns. Click OK and then 
click Finish.

16. When you see the confirmation screen, click Close. 

17. From the Details pane, drag and drop additional elements to the center pane (optional). 

18. From the Home tab, click Publish All.
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To Create a SQL tabular Scorecard
1. On the Create tab of the Ribbon, click Scorecard.

2. In the Select a Scorecard Template dialog box, click Tabular and then the SQL Tabular template. Click 
OK.

3. Specify the scorecard name and default display folder location. The default display folder is an optional 
feature that can help you organize your scorecards in the Workspace Browser.

– Select the Grant Read permission to all authenticated users on the PerformancePoint 
Scorecard server check box (optional)

4. Select the data source from either the Workspace or Server tab. Click Next. Note: Click Refresh to 
ensure you are viewing the current list of defined data sources. 

5. Add new key performance indicators (KPIs) by clicking Add KPI for every KPI you want to add. Adjust 
the settings for each KPI as needed OR

6. Click Select KPI to select a pre-defined KPI from either the Workspace or Server tab. Click OK. Repeat 
this step for each additional pre-defined KPI you wish to add. Click Refresh to ensure you are viewing 
the current list of defined data sources. 

7. Click Next. 

8. Select the Add measure filters checkbox to add measure filters for the Scorecard KPIs.

9. Click Select Dimension. Select the dimension you want, and then click OK.

10. Click Select Member to select the specific members for the Actual measure filter. Click OK.

11. Click Select Member to select the specific members for the Target measure filter. Click OK. 

12. Click Next. 

13. Select the Set members for the columns checkbox to create a matrix style view for your scorecard.

14. Click Select Dimension. Select the dimension for the columns (typically time), and then click OK.

15. Click Select Member. Select the specific members to be displayed on the columns. Click OK and then 
click Finish.

16. When you see the confirmation screen, click Close. 

17. From the Details pane, drag and drop additional elements to the center pane (optional).

18. From the Home tab, click Publish All.
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To Create a SharePoint List Scorecard
1. On the Create tab of the Ribbon, click Scorecard.

2. In the Select a Scorecard Template dialog box, click Tabular and then the SharePoint List template. 
Click OK.

3. Specify the scorecard name and default display folder location. The default display folder is an optional 
feature that can help you organize your scorecards in the Workspace Browser.

– Select the Grant Read permission to all authenticated users on the PerformancePoint 
Scorecard server check box (optional).

4. Select the data source from either the Workspace or Server tab. Click Next. Note: Click Refresh to 
ensure you are viewing the current list of defined data sources. 

5. Add new key performance indicators (KPIs) by clicking Add KPI for every KPI you want to add. Adjust 
the settings for each KPI as needed OR

6. Click Select KPI to select a pre-defined KPI from either the Workspace or Server tab. Click OK. Repeat 
this step for each additional pre-defined KPI you want to add. Click Refresh to ensure you are viewing 
the current list of defined data sources. 

7. Click Next.

8. Select the Add measure filters checkbox to add measure filters for the Scorecard KPIs.

9. Click Select Dimension. Select the dimension needed, and then click OK.

10. Click Select Member to select the specific members for the Actual measure filter. Click OK.

11. Click Select Member to select the specific members for the Target measure filter. Click OK. 

12. Click Next. 

13. Select the Set members for the columns checkbox to create a matrix style view for your scorecard.

14. Click Select Dimension. Select the dimension for the columns (typically time), and then click OK.

15. Click Select Member. Select the specific members to be displayed on the columns. Click OK and then 
click Finish.

16. When you see the confirmation screen, click Close. 

17. From the Details pane, drag and drop any additional items to the center Workspace (optional). 

18. On the Home tab, click Publish All.
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Adding Elements to Scorecard

• Start by adding the KPIs tot create the basic structure. From that point Dimensionality and aggregation 
points are added by dragging the appropriate dimensions to either the column or row locations.
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To Export to SQL Reporting Services

1. On the Home tab of the ribbon, click Refresh and then Publish All.

2. Click the Export tab of the Ribbon, and then click SQL Server Reporting Services.

3. Select the scorecard you want to export. Click Refresh to verify you are viewing the current list that 
has been published to the server. 

4. Click Next.

5. Choose whether you want to deploy the scorecard to SQL Server Reporting Services or to a file. Click 
Next.

6. If you selected Deploy SQL Server Report to a Reporting Services server:

a) In the SQL Server Report Name text box, type a name for the Reporting Services report. The 
name you enter will appear in the URL for the report.

b) In the Measurement System drop-down list box, select either inches or centimeters as the unit 
of measure for the report layout

c) In the Reporting Services location text box, type or select the URL of the Reporting Services 
server to which you are deploying the report. 

d) In the Deployment Folder text box, type the name of the folder in which the Reporting Services 
report is to be stored.

e) Click Finish.

7. If you selected Save SQL Server Report to file system:

a) In the SQL Server Report Name text box, type a name for the Reporting Services report.

b) In the Measurement System drop-down list box, select either inches or centimeters as the unit 
of measure for the report layout.

c) Click Finish. A Save As dialog box will open, allowing you to save the report file to a location of 
your choice. The file will be save as a Reporting Services file with an .rdf extension. Click Save.

8. At the Confirmation screen, click Close.
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KPI

Key performance indicators (KPIs) are business metrics that help decision makers at all 
levels of the organization monitor progress toward meeting organizational performance 
goals. They are one of the core scorecard elements that you create in PerformancePoint 
Scorecard Builder. KPIs can provide a logical and comprehensive way of describing 
organizational strategy when organizational stakeholders carefully plan what KPIs to use in 
their scorecards.

All KPIs in PSC must be associated with an actual value and one or more target values. To 
determine how much progress has been made toward the organization's performance goal, 
the actual value and the target values of the KPI are compared in the business scorecard. 
You can define multiple targets for a single KPI. For example, you could have a KPI called 
"Sales" that has the three target values:

The actual value is the value for any KPI at a specific point in real time. The target value or 
values represent the desired level of performance as measured by the KPI with respect to a 
business goal or strategy. 

Each key performance indicator (KPI) that you create in Scorecard Builder should be closely 
aligned with a specific organizational, departmental, or functional unit or with a specific 
business strategy or goal. This alignment makes it possible for individual employees in the 
organization to monitor the KPIs that apply to their areas of responsibility and for the 
organization to ensure that business actions align with defined goals and strategies.
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Module 1: BSM Fundamentals
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There are three common terms used when referring to scorecards, Objectives, Key 
Performance Indicators (KPIs), and Targets.

Objectives

• Objectives are statements of goals for the organization. Some examples are:

• Increase customer confidence in our advice

• Increase the number of new products introduced

• Decrease the number of defects in our products

• A scorecard can contain one or more objectives.

KPIs

• Each objective is measured by a set of KPIs.  The KPIs track the performance of the objective.  Some 
sample KPIs for the objectives above are:

• % of customers surveyed who rate us as their top source of advice

• Number of products introduced per quarter

• Number of defects per 1000 manufactured

Targets

• Targets are the numeric goals for a KPI. For example:

• How many new products are we aiming to introduce this quarter?

• How many defects per 1000 is an acceptable goal for this quarter? 



Creating KPIs
• Creating a key performance indicator (KPI) in Dashboard Designer is a multi-step process that includes 

the naming and setting of permissions; creating and defining the actual and target values for each KPI; 
and setting the scoring patterns (banding) methods. KPIs must be defined before they can be used in a 
Scorecard.

Note: 
• When you create a new KPI, the default mapping is to a fixed value of 1. To map your KPI to another 

source, such as a multidimensional or ODBC data source, click on the Data Mappings link on the KPI 
Summary tab.

To create a new KPI
1. Click the Create tab in the Ribbon, and then click KPI.

2. In the Select a KPI Template Wizard, click the Blank KPI icon, and then click OK.

3. Enter a name for the KPI in the Name text box (required).

4. If desired, you may name a new default display folder location. These folders appear in the Workspace 
Browser pane and are useful for organizing multiple data sources.

5. To grant read permission to all authenticated users, click the box provided for that purpose.

6. When finished, click OK. The name of this data source now appears in the Workspace Browser under 
Data Sources.

7. On the Summary tab, click Data Mappings. By default the KPI data mapping is set to Fixed Values. Either 
change the current value of 1 (if necessary) or click Change Source to map your KPI to a different data 
source.

8. To change the data sources, click Change Source. Highlight the data source desired from either the Server 
or Workspace tab, and then click OK. Note: Click Refresh to ensure that you are viewing the current list of 
all data sources on the server and workspace. 

9. A dimensional data source mapping screen will display. Select the desired measure from the dropdown 
list.

10. Click the Select member icon. A Dimension selector window will display. Highlight the desired dimension 
and then click OK.

11. On the Home tab, click Publish All.
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Objective KPI

• In Dashboard Designer, you can create scorecards that contain both key performance indicators (KPIs) 
and objectives. An objective is a collection of related KPIs or objectives. Create an objective to logically 
group KPIs or create subsets under larger objectives. For example, you could create an objective 
called "Regional Sales" and then subsets of objectives for each Region.

To Create a New Objective KPI

1. Click the Create tab in the Ribbon, and then click KPI.

2. In the Select a KPI Template click Objectives, and then click OK.

3. Enter a name for the KPI in the Name text box (required).

4. If desired, you may name a new default display folder location. These folders appear in the Workspace 
Browser pane and are useful for organizing multiple data sources.

5. Select Grant Read permission to all authenticated users to PerformancePoint Monitoring Server if 
desired.

6. When finished, click OK. The name of this Objective now appears in the Workspace Browser under 
KPIs.
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To Edit a KPI Calculation

1. From the left Workspace Browser pane, double-click on the KPI you wish to edit.

2. Click once on the link in the Calculations column you wish to edit.

3. Optionally, clear the checkbox of Use calculated values of Actual and Target to compete the score. 

4. In the Calculation dialog box that displays, select the type of calculation (if any) you wish to have 
performed. Click OK.
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Setting scoring patterns and indicators

1. From the Workspace browser, double-click the KPI you wish to edit. Note: This step also occurs within 
the Create a New KPI Wizard.

2. In the center Workspace pane, highlight a Target KPI.

3. Click Set Scoring Pattern and Indicator in the Thresholds box.

4. Select a scoring pattern.

5. Select a banding method.

6. Click Next.

7. Select an Indicator. Click Next.

8. Enter a worst value. Click Finish.
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All key performance indicators (KPIs) must be associated with an actual value that you 
either enter manually as a fixed value or that is retrieved from a data source. 

You might find it useful to manually enter an actual value when you are prototyping a 
scorecard or when data sources are not yet available. The actual value for a KPI is 
compared 

to the target value or values for that KPI to determine how much progress has been 
made toward the KPI performance goal.

At this stage you have already used the KPI wizard to create a KPI, and should now be in 
the Workspace Summary ready to set your actual and target values.
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Setting Actual Values

• If desired, enter a new name to replace Actual in the Name table cell.

• In the Display Format column, click Default to see what the default values are. You may change them 
by selecting Override Display Format. Click OK when done.

• In the Data Mappings column, the default value is 1. To change the default value, click inside the cell 
and a dialog box opens. Enter the new number and click OK. 

• Data mapping refers to how you can derive the actual value for a key performance indicator (KPI) from 
a data source, or specify a fixed value (a manually entered value) for the actual value. Fixed values are 
useful for creating prototype scorecards or for situations where data sources have not yet been 
created or are not yet mapped to KPI actual or target values. 

• In the Calc Type column, a default setting means that its value will be derived from your data source, 
or, you can specify a fixed value by clicking in the cell, and choosing from a list of options in the dialog 
box that opens. Once this fixed value is selected, click OK.the KPI wizard to create a KPI, and should 
now be in the Workspace Summary ready to set your actual and target values.
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Setting Targets

• If desired, enter a new name to replace Target in the Name table cell.

• In the Display Format column, click Default to see what the default values are. You may change them 
by selecting Override Display Format. Click OK when done.

• In the Threshold column, click inside the cell and the Set Band Pattern button appears in the 
Thresholds section of the Workspace. See Thresholds procedures below for more information.

• In the Data Mappings column, the default value is 1. To change the default value, click inside the cell 
and a dialog box opens. Enter the new number and click OK. 

• In the Calc Type column, a default setting means that its value will be derived from your data source, 
or, you can specify a fixed value by clicking in the cell, and choosing from a list of options in the dialog 
box that opens. Once this fixed value is selected, click OK.
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Adjusting Thresholds

1. Click inside the Threshold cell. The Set Scoring pattern and Indicator button appears in the Thresholds 
section of the Workspace Summary.

2. Click Set  scoring Pattern..

3. In the Edit Band Settings dialog box, in the Scoring pattern window, click inside the field and then click 
which of the 3 patterns that you want.

4. In the Banding method window, click inside the field, click which of the 3 methods that you want, and 
then click Next.

5. 5. Select the indicator, and then click Next.

6. 6. Enter the worst-case threshold value (if not zero), and then click Finish.
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Step 3

• In the Edit Band Settings dialog box, in the Scoring pattern window, click inside the scoring pattern 
field and then click which of the 3 patterns that you want.
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Step 4

• Click inside the Banding method field, click which of the 3 methods that you want, and then click Next.
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Step 5

• Select the indicator, and then click Next.
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Step 6

• Enter the worst-case threshold value (if not zero), and then click Finish.
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Modifying the Print Mask and Display Format for KPIs

• By default, Dashboard Designer sets the default format to the standard of two decimal places and a 
multiplier of one. The display format can be customized to meet your needs including tool tip text, the 
print mask, where the symbols display and other formatting preferences.

To Modify the Print Mask and Display Format for KPIs

1. From the left Workspace Browser pane, double-click on the KPI you wish to edit.

2. Click once on the link in the Display Format column you wish to edit.

3. Select the Override Display Format checkbox.

4. Change the formatting and print masks as desired.

5. Click OK.
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Leaf-level Standard KPIs.

• These KPIs do not have child KPIs underneath them in the scorecard hierarchy. For these KPIs, select 
the Use calculated values of actual and target to compute score in the Calculation dialog box. Leaf-
level KPIs, are shown as a value in the scorecard. This value can be explicit or it may originate in a cube 
(where it may be the result of a calculation). It is never the result of a scorecard calculation.

Non-leaf-level Standard KPIs

• These KPIs have one or more KPIs underneath them in the scorecard hierarchy. In other words, these 
are KPIs that have children. For these KPIs, select the Use calculated values of actual and target to 
compute score in the Calculation dialog box. This is the only type of KPI that you should use in a 
scorecard calculation.

Non-leaf-level Objective KPIs

• This type of KPI is always shown as an indicator. It is never shown as a value. Objective KPIs are non 
leaf level KPIs or KPIs that have one or more KPIs underneath them in the scorecard hierarchy. In other 
words, they are like non-leaf-level standard KPIs, KPIs that have children. To define a KPI as an 
Objective, clear the Use calculated values of actual and target to compute score” in the Calculation 
dialog box. An objective KPI is an averaged rollup of all children of that KPI. It is shown as an indicator, 
not as a value. If you want to show a value, create a calculation by using a non-leaf-level standard KPI

Note: 

• You can turn a standard KPI of either type into an objective KPI by selecting the Use calculated values 
of actual and target to compute score check box in the Calculation dialog box.
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To Edit a KPI Calculation

1. From the left Workspace Browser pane, double-click on the KPI you wish to edit.

2. Click once on the link in the Calculations column you wish to edit.

3. Optionally, clear the checkbox of Use calculated values of Actual and Target to compete the score. 

4. In the Calculation dialog box that displays, select the type of calculation (if any) you wish to have 
performed. Click OK.
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Setting scoring patterns and indicators

1. From the Workspace browser, double-click the KPI you wish to edit. Note: This step also occurs within 
the Create a New KPI Wizard.

2. In the center Workspace pane, highlight a Target KPI.

3. Click Set Scoring Pattern and Indicator in the Thresholds box.

4. Select a scoring pattern.

5. Select a banding method.

6. Click Next.

7. Select an Indicator. Click Next.

8. Enter a worst value. Click Finish.
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Indicator Overview

• There are two general categories of Indicators: Standard and Centered. Standard indicators use a 
pattern that is linearly increasing. For example, as revenue increases, you get closer to your target 
revenue. The status of the KPI changes from as values increase.

• Centered indicators use a different pattern, where the target is a specific value. For example: A plant 
has an optimal capacity for manufacturing widgets. If they produce less they are under utilizing their 
resources, but it is over that number it creates downstream problems for their vendors in cargo. The 
closer they are to the target, the better the score. Further away from the target value, either above or 
below, decreases the score. With a centered indicator, you can define status bands both above and 
below the value of your target.
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Creating Indicators

• You have the choice of creating either a standard or centered indicator type. Standard indicators use a 
pattern that increases linearly. For example, as revenue increases and you get closer to the target 
revenue, the status of the key performance indicator (KPI) changes from red to green as the values 
increase.

• Centered indicators use a different pattern as the target is a specific value. The closer you get to this 
target, the better the score. With a centered indicator you can define status bands both above and 
below the value of your target.

Steps to create an indicator

1. In the Create tab of the Ribbon, click Indicators.

2. In the Select an Indicator Template Wizard, choose an indicator by clicking the one you want to add—
they are grouped as Centered or Standard, as well as by type—and then click OK. The indicator now 
appears in the Workspace Browser under Indicators.
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Custom Indicators

• Create a custom indicator for a scorecard by using the Create Indicator Wizard. When you create a 
custom indicator, you have the choice of defining the properties including the image, text and 
background color and number of levels. 

Steps for Custom Indicators

1. In the Create tab of the Ribbon, click Indicator.

2. In the Select an Indicator Template wizard, click and then Blank Indicator.

3. Type a name for your new Indicator in the Name text box (required). If desired, you may specify a new 
default display folder location in the Default display folder location text box. These folders appear in 
the Workspace Browser pane and are useful for organizing. To grant read permission to all 
authenticated users, select the Grant read permission to all authenticated users on the 
PerformancePoint Scorecard server check box.

4. Click Next. Designate the type of indicator by selecting either Standard or Centered. 

5. Select the number of levels, and then click Finish.

6. On the Summary pane, double-click the icon under the Image column and select your custom image 
from your desktop and then click Open. Repeat for each level.

7. Double-click the icon under the Text Color column and select the color of the indicator text.

8. Double-click the icon under the Background column and select the color of the background. Repeat for 
each level.
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Editing

• A large set of indicator images is provided in Dashboard Designer for each indicator band. Dashboard 
Designer provides the ability customize the by changing the text color or the background. You can also 
change the indicator image entirely. 

• When you add a new indicator to a target value, you must create a .gif, .jpg, or .png image for each 
band. You can create images in any of the three sizes (small, medium, or large).

• It is recommend that you use the following indicator image sizes in Dashboard Designer when you 
create new indicators: Small: 80 x 22 pixels; Medium: 65 x 124 pixels; and Large: 87 x 175 pixels.

Steps to Edit

1. On the Workspace Browser pane, double-click the indicator you wish to edit.

2. In the workspace Summary tab, double-click on the image you wish to edit. Browse for your new 
image. (optional).

3. To edit the text color, double-click on the value under the Text Color column. Select a standard color 
from the dialog box or click Define Custom Colors to define a new color. Click OK. 

4. To edit the background color, double-click on the value under the Background Color column. Select a 
standard color from the dialog box or click Define Custom Colors to define a new color. Click OK.
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• In Dashboard Designer, you can create analytic charts based on a SQL Server 2005 Analysis Services data source that has 
been published to the server. First you create the basic structure for the report, and then you apply measures, 
dimensions, or named sets to display data. You can also adjust report properties (such as report name and location), 
permissions (so others can use and view a report), and custom settings.

To create the basic structure for an analytic chart report

1. Click the Create tab, and then click Analytic Chart to open the Create Analytic Chart Report Wizard.

2. Type a name for the report, select the folder location and user access options, and then click Next.

3. Select the Analysis Services 2005 data source that you want to use, and then click Finish.

4. When the report has been created, click Close. At this point, the basic structure has been created for the analytic chart. 
To display data, at least two items (such as measures, dimensions, or named sets) must be applied to the chart (see 
later in this Help topic).

To display data in the analytic chart

1. Click the Design tab in the workspace and make sure that the Details pane is displayed.

2. From the Details pane, drag at least one dimension, measure, or named set into the Series or Bottom Axis sections in 
the workspace. If you want to, you can also put one or more items in the Background section, which will serve as a 
hidden filter in the report. When you put at least one item in each of the series and bottom axis sections, the report 
automatically generates and displays the results.

3. Note: All selected measures will be in the same section. For example, if you put one or more of the measures in the 
series section, you cannot put measures in the bottom axis, too. Dashboard Designer automatically moves all the 
measures to the same section. 

4. Click the Home tab, and then click Publish All.

To adjust member selections and change the data displayed in the chart

1. Right-click a dimension and then click Select Members on the shortcut menu. This opens the Member Selector dialog 
box. 

2. Either right-click a dimension or expand the tree. Then select the members you want your report viewers to see. 

3. If you want to, you can select the Default Member check box. This option creates a default view for report users who 
may not have the permissions necessary to drill down or view data for individual members. 

4. When you finish selecting members, click OK to close the Member Selector dialog box. 
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• In Dashboard Designer, you can create analytic grid reports based on a SQL Server 2005 Analysis Services data 
source that has been published to the server. First you create the basic structure for the report, and then you 
apply measures, dimensions, or named sets to display data. You can also adjust report properties (such as report 
name and location), permissions (so others can use and view a report), and custom settings.

To create the basic structure for an analytic grid 

1. Click the Create tab, and then click Analytic Grid to open the Create Analytic Grid Report Wizard.

2. Type a name for the report, select the folder location and user access options, and then click Next.

3. Select the Analysis Services 2005 data source you want to use, and then click Finish.

4. When the report has been created, click Close. At this point, the basic structure has been created for the analytic 
grid. To display data, at least two items (such as measures, dimensions, or named sets) must be applied to the 
grid (see later in this Help topic).

To display data in the analytic grid

1. Click the Design tab in the workspace and make sure the Details pane is displayed.

2. From the Details pane, drag at least one dimension, measure, or named set into the Rows or Columns section in 
the workspace. If you want to, you can also put one or more items in the Background section, which serves as a 
hidden filter in the report. When you put at least one item in each of the rows and columns sections, the report 
automatically generates and displays the results. 

3. Note: All selected measures will be in the same section. For example, if you put one or more of the measures in 
rows, you cannot put measures in columns, too. Dashboard Designer automatically moves all of the measures to 
the same section. 

4. Click the Home tab, and then click Publish All.

To adjust member selections and change the data displayed in the grid

1. Right-click a dimension and then click Select Members on the shortcut menu. This opens the Member Selector 
dialog box. 

2. Either right-click a dimension or expand the tree. Then select the members you want your report viewers to see. 

3. If you want to, you can select the Default Member check box. This option creates a default view for report users 
who may not have the permissions necessary to drill down or view data for individual members. 

4. When you finish selecting members, click OK to close the Member Selector dialog box. 
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ProClarity Analytics Server Reports
• In Dashboard Designer, you can easily create ProClarity Analytics Server Page reports that bring ProClarity 6.3 

views into your dashboard. These views include the Decomposition Tree, Perspective View, Performance Map, 
Pareto Chart, and analytic charts and grids that have been published to ProClarity Analytics Server.

To create the basic structure for a ProClarity Analytics Server Page report
1. Click the Create tab, select Other Reports, and then click ProClarity Analytics Server Page to open the wizard.

2. Type a name for the report, select the folder location and user access options, and then click Next.

3. When the report has been created and the confirmation screen appears, click Close. At this point, you have 
created the basic structure for the ProClarity Analytics Server Page report. To display data in the report, you must 
connect to ProClarity Analytics Server and select the page you want to use.

4. On the Home tab, click Publish All.

To connect to ProClarity Analytics Server and select a page to display
1. On the Editor tab of the workspace, type the URL to the computer that is running ProClarity Analytics Server that 

contains the reports you want to use. This makes the Browse button available. (The Browse button remains 
unavailable if anything other than a valid URL to the server is entered.)

2. Click the Browse button to open the ProClarity Analytics Server Browser dialog box.

3. Use one of the following methods to log on to ProClarity Analytics Server:
1. Select the Use Windows Credentials check box.
2. Type a User Name, Password, and Domain.

4. In the pane immediately under the logon credentials, expand the libraries and books, and select the ProClarity 
Analytics Server page that you want to use.

5. Click OK. This associates the ProClarity Analytics Server page with the ProClarity Analytics Server Page report and 
closes the wizard. On the Editor tab in the center pane, you see the selected page where you typed the server 
URL.

6. On the Home tab, click Publish All.

To set configuration options for the ProClarity Analytics Server Page report
1. On the Editor tab of the center pane, either type the ProClarity Analytics Server uiConfig setting that you want to 

use, or click the down arrow to select one of the most frequently used options. For more information on uiConfig
settings, refer to the ProClarity Analytics Server documentation.

2. On the Home tab, click Publish All.
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Strategy Maps
• Dashboard Designer enables you to use existing Microsoft Office Visio diagrams to graphically represent a measured strategy as a

flowchart or diagram. As a counterpart to a scorecard, the strategy map makes it easy to see and understand interrelationships and 
dependencies among key performance indicators (KPIs), goals, and objectives.

• A strategy map is a flowchart or diagram depicting a visual representation of a process. It is created in Dashboard Designer through 
a window that opens a workspace in Office Visio 2007. After the strategy map is created, you can save it to the Dashboard Designer 
database like any other report and then attach it to a dashboard and export it to a Windows SharePoint Web page.

• Office Visio 2007 Viewer enhances what the user can do with a strategy map report by extending the user's ability to view Visio 
drawings and diagrams inside the Web browser. If Office Visio 2007 Viewer is installed on the client computer, Windows Internet 
Explorer opens the strategy map in the browser window. Users can use toolbar buttons, keyboard shortcuts, and right-click menu 
options. Additionally, drawing-layer visibility and colors can be set on the Layer Settings tab, and annotation visibility and colors can 
be set on the Markup Settings tab.

To create the structure for a strategy map report
1. Click the Create tab, and then click Strategy Map.

2. In the Select a Report Template dialog box, click Strategy Map, and then click OK. 

3. Note: You can also create a strategy map report by clicking Other Reports and then selecting Strategy Map. 

4. Type the strategy map name in the Name text box, and specify the folder display location and user access options. You can create or 
select a new folder location by clicking Select Display Folder. The folder you specify appears in the Workspace Browser pane, which 
is useful for organizing multiple reports.

5. Select a scorecard to use for the strategy map, and then click Finish. This sets up the basic structure for your strategy map and 
displays a confirmation screen. 

6. On the confirmation screen, click Close. Your strategy map is now available for editing in the workspace.

To add content to the strategy map
1. Click the Edit tab, and then click Edit Strategy Map. This opens the Strategy Map Editor dialog box.

2. In the Strategy Map Editor dialog box, click Open Visio File. Browse and select your existing Visio diagram.

3. Click a shape that you want to connect to a KPI, and then click Connect Shape. This opens the Select a KPI dialog box.

4. In the Select a KPI dialog box, select a KPI and a column, and then choose whether to add the KPI name to the shape in the diagram. 
Click OK.

5. Repeat steps 1 through 4 for each additional shape you want to tie to a KPI value. 

6. To remove a connection to a shape, select the shape and then click Disconnect.

7. You can use the Resize to Fit and Fit for Print buttons to adjust the page size.

8. When you finish editing the strategy map, click Apply. This closes the Strategy Map Editor dialog box and returns you to the 
workspace for the strategy map. 

9. In the workspace, click the Editor tab. The diagram you just created or edited by using the Strategy Map Editor dialog box should 
appear in the Strategy Map pane.

10. Repeat steps 1 through 9 until your strategy map is correctly set up.
11. Click the Home tab, and then click Publish All.
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To create a trend analysis chart

1. Click the Create tab in the Ribbon, and then click Other Reports.

2. In the Select a Report Template Wizard, click Trend Analysis Chart, and then click OK.

3. Type the PivotTable name in the Name text box (required). If desired, you may specify a new default 
display folder location in the Default display folder location text box. These folders appear in the 
Workspace Browser pane and are useful for organizing multiple reports.To grant read permission to all 
authenticated users, select the Grant read permission to all authenticated users on the 
PerformancePoint Scorecard server check box.

4. Click Next. 

5. Select a scorecard to use in your report. Click Next. 

6. Select the KPIs and values to be included in your report.

7. Click Finish. Once the Confirmation screen appears, click Close. The name of this report now appears in 
the Workspace Browser under Reports.

8. On the Summary tab, click on the Select X-Axis box to change the X-Axis (optional).

To Select Time Period Settings:

1. On the Summary tab, scroll the bottom pane to view the possible options.

2. Define the History Period by selecting either Use Selection or Use last trailing periods. 

To Set Data Mining Algorithm Parameters

1. On the Summary tab, scroll the bottom pane and click Advanced Settings.

2. In the Set Data Mining Algorithm Parameter box, adjust the values as needed for the following SQL 
parameters:
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To set up the basic structure for your SQL Server Reporting Services reference report
1. Click the Create tab, and then click Other Reports.

2. In the Select a Report Template dialog box, click SQL Server Report, and then click OK.

3. Type the report name in the Name text box and specify the folder display location and user access options. 
You can create or select a new folder location by clicking Select Display Folder. The folder you specify will 
appear in the Workspace Browser pane, which is useful for organizing multiple reports.

4. Click Finish. This will set up the basic structure for your report reference and display a confirmation screen. 
On the confirmation screen, click Close. Your report is now available for editing in the workspace.

To configure the Reporting Services reference report
1. Click the Editor tab, and type the server location where your SQL Server data resides in the format 

http://<server name>:<Reporting Services port if not default>/reportserver.

2. Click Browse to select the Reporting Services report name. (This report must already be in the SQL Server.)

3. Select the Show toolbar check box if you want to make the SQL Server toolbar display on the report Web 
part.

4. Select the Show parameters check box if you want to make the SQL Server report parameters included on 
the report to filter a large set of records.

5. Select the Show docmap check box if you want your report view to include a document map. (A separate 
side pane appears next to the report when this check box is selected.)

6. In the Zoom box, select the viewing size of the report.

7. In the Format box, select the format of the report.

8. In the Section box, type the section heading you want to use in the report.

9. In the DocMap ID box, type the docmap number.

10. In the Report Parameters section, click Edit to make adjustments.

11. A preview of the SQL Server Reporting Services report will display in the lower pane of the Summary tab. You 
can make adjustments by repeating the steps above until the report is set up the way you want it to display 
in the Dashboard.
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Pivot Charts
• In Dashboard Designer, you can display scorecard data in a PivotChart report format. A PivotChart 

report provides a graphical representation of the data that you would see in a regular PivotTable 
report. PivotChart reports enable you to change the layout and data displayed, just as you can using a 
PivotTable report.

To create the basic structure for a PivotChart report
1. Click the Create tab, and then click PivotChart.

2. Type the report name in the Name text box, and specify the folder display location and user access 
options. You can create or select a new folder location by clicking Select Display Folder. The folder that 
you specify appears in the Workspace Browser pane, which is useful for organizing multiple reports.

3. Click Finish. This sets up the basic structure for your report and displays a confirmation screen. On the 
confirmation screen, click Close. Your report is now available for editing in the workspace.

To add data to the PivotChart report
1. On the Editor tab in the workspace (center pane), click the Chart Wizard toolbar button. This opens the 

Commands and Options dialog box.

2. On the Data Source tab (in the Commands and Options dialog box), specify where the PivotChart data 
will come from. This adds the Data Details and Type tabs to the Commands and Options dialog box.

3. On the Data Details tab (in the Commands and Options dialog box), create the data connection or 
specify where the data will come from. 

a) You can click the Edit button to open the Data Link Properties dialog box, which enables you to 
specify provider, connection, and advanced settings for the data source. When you click OK in 
this dialog box, you may be prompted to log on to the server hosting the data.

b) If you see the Data Source Logon dialog box, type the user name and password to the server 
where the data resides, and then click OK to complete the connection.

4. On the Type tab (in the Commands and Options dialog box), select the chart type you want to use for 
the PivotChart report.

5. Use the Microsoft Office Excel toolbar options that are available in the workspace (center pane) to 
further define the PivotChart report. 

6. When you are finished adding data to the report, click the Home tab, and then click Publish All.
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Pivot Tables

• Dashboard Designer helps you create a report that references existing PivotTable data in Microsoft Office Excel 
2007. PivotTable reports make it easy to work with large volumes of data. PivotTable reports also allow you to 
change the layout and data displayed. 

• In Dashboard Designer, the PivotTable report uses the standard controls in Microsoft Office Web Components. 
You need to have Office Web Components installed on the same computer as Dashboard Designer. 

To create the structure for your PivotTable report

1. Click the Create tab, and then click Other Reports.

2. In the Select a Report Template dialog box, click PivotTable, and then click OK.

3. Type the report name in the Name text box, and specify the folder display location and user access options. You 
can create or select a new folder location by clicking Select Display Folder. The folder that you specify appears in 
the Workspace Browser pane, which is useful for organizing multiple reports.

4. Click Finish. This sets up the basic structure for your report and displays a confirmation screen. On the 
confirmation screen, click Close. Your report is now available for editing in the workspace.

To add data to the PivotTable report

1. On the Editor tab in the workspace (center pane), click the Commands and Options toolbar button. This opens the 
Commands and Options dialog box.

2. On the Data Source tab, create the data connection or specify where the data will come from. 

a) You can click the Edit button to open the Data Link Properties dialog box, which enables you to specify 
provider, connection, and advanced settings for the data source. When you click OK in this dialog box, you 
may be prompted to log on to the server hosting the data.

b) If you see the Data Source Logon dialog box, type the user name and password to the server where the 
data resides, and then click OK to complete the connection.

3. On the Behavior tab, select the Hide/Show options and General options. Then click the Protection tab.

4. On the Protection tab, select the options you want to apply to your PivotTable report.

5. Use the Microsoft Office Excel toolbar options that are available in the workspace (center pane) to further define 
the PivotTable report. 

6. When you are finished adding data to the report, click the Home tab, and then click Publish All.
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To Create a Spreadsheet Report

• Click the Create tab, and then click Other Reports.

• In the Select a Report Template Wizard, click Spreadsheet, and then click OK.

• (Required) Type the report name in the Name box. 
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Web Page Reports

• In Dashboard Designer, you can create a reference to an existing Web page and then include it in a 
dashboard that is deployed to Windows SharePoint Services. This is useful for providing online 
information alongside other elements in a dashboard.

To create a Web page report

1. Click the Create tab, and then click Web Page. 

2. Note: You can also create a Web page report by clicking Other Reports and selecting Web Page. 

3. Type a name for the Web page report in the Name text box. 

a) If you want to, you can name a new default display folder location. These folders appear in the 
Workspace Browser pane and are useful for organizing multiple reports.

b) To grant Read permission to all authenticated users, select the Grant Read permission to all 
authenticated users check box.

4. Click Finish. After the confirmation screen appears, click Close.

5. On the Editor tab, type the complete URL of the Web page that you want to reference, starting with 
http://, in the URL text box.

6. In the Web Page section, you should see the Web page associated with the URL you entered in step 4.

7. Click the Home tab, and then click Publish All.
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Dashboard Fundamentals

• The purpose of the dashboard feature is to build a dashboard page (or multiple pages inside a 
dashboard) that contains one or more scorecards and reports. Each report can be linked with a report 
parameter. Users can add, remove, or drag-and-drop a dashboard item on the design canvas, link a 
dashboard item with a parameter, and use plug-in dashboard applications in the workspace.

• A dashboard is defined as "a related group of interactive scorecard and report views that are organized 
together in a single SharePoint site. Dashboard elements may share common filters that control the 
data displayed within the elements."

• A dashboard can contain one or more dashboard pages, and a dashboard page can contain one or 
more dashboard zones. A dashboard zone can contain one more dashboard items. A user always 
publishes the complete dashboard.

Dashboards Contain

• Dashboard page

• Dashboard zone

• Dashboard item

• Scorecard

• Report Views ( Report Links)

• Parameters
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Dashboard Page 

• The dashboard page is a container for the dashboard zones. When publishing to SharePoint Services or 
Preview, one dashboard page equals one Web Part page

• From SharePoint each page will show up as an individual tab or individual pages depending on the 
SharePoint setup
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Steps for creation

1. Click the Create tab in the Ribbon, and then click Dashboard.

2. In the Select a Dashboard Template Wizard, click the desired layout icon, and then click OK.

3. Type the Dashboard name in the Name text box (required). 

4. If desired, you can designate a new folder in Default display folder location text box. These folders 
appear in the Workspace Browser pane and are useful for organizing multiple data sources.

5. To grant read permission to all authenticated users, select the Grant Read permission to all 
authenticated users on the PerformancePoint Scorecard Server check box.

6. When finished, click OK. The name of the Dashboard now appears in the Workspace Browser under 
Dashboards. 

7. From the Details pane, drag and drop any additional elements onto the center Workspace pane.

8. On the Home tab click Publish All. This publishes the Dashboard to the server.
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To Adjust Width and Zone Heights 

1. On the Workspace Browser, double-click on the Dashboard you want to edit.

2. On the Summary tab in the center Workspace pane, click the edit arrow on the element you want to 
edit and then select Edit Item from the shortcut menu. The Edit Item box will display.

3. Click the Size tab.

4. Under Width, select either to auto-size the item width, specify a percentage of the dashboard, or 
indicate a pixel setting. The maximum width is 100%.

5. Under Height, select either to auto-size the item height, specify a percentage of the dashboard, or 
indicate a pixel setting. The maximum height is 45%.

6. Click OK.
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Adding Elements

• Drag and drop elements from the right hand side of the dashboard designer to the appropriate zone 
locations. Once the proper relationship is created, filters and links can be created.
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Creating Filters
• Dashboard Designer allows you to create a filter on your Dashboard items to help the user manage 

large amounts of data on a deployed Dashboard. The filter list can be created by selecting any one of a 
number of data source options. After the list is created it does not have a live connection to the data 
source; it is simply a list. 

• If you want to link the filter to more than one dashboard element, it is important for you to know if 
similar data is referenced by those other elements. For example, if you create a filter list comprised of 
countries, and you want to link that to more than one scorecard, make certain that country data is 
stored in each of the data sources associated with each scorecard.

Filter with a Set of Members 
• Create a filter by browsing your cube data to select a set of members from different dimensions.

Filter with an MDX formula 
• An advanced method of creating a filter The filter list created is from the results of an MDX query.

Filter with a Named Set 
• Filter with a named a set of dimension members that have been predefined by using creating a query 

on cube data.

Filter with Tabular values 
• Create a filter list from a tabular data source with the ability to specify columns as keys and indicate 

display names.

Filter using Time Intelligence members 
• Create a filter built on time intelligence members and your formulas.

Filter using Time Intelligence Post Formula 
• Create a filter that allows the user to select the current time from a Calendar.

Module 4: Dashboards

Microsoft Confidential Page: 9



1. After creating the Dashboard, click the Filter tab in the workspace pane in the center of the screen.

2. Click New Filter.

3. In the Select a Dashboard Filter Template wizard, select Member Selection, and then click OK.

4. Type a filter name in the Name text box.

5. Type a description of the filter in the Description text box (optional).

6. Click Next.

7. Select a data source for the filter from the list displayed. If you do not see the data source that you 
need, click Refresh to update the list from the server. Click Next. 

8. Click Select Dimension. Select the filter dimension from the list displayed. Click OK.

9. Click Select Members. Select the filter Members from the list displayed. Expand folders if necessary to 
display all data. Click OK.

10. Choose how you want the filter to display on the Dashboard: A list, a tree or a multi-tree format. Click 
Finish.

11. If the filter is successfully created, a confirmation page will display. Click Close. 

12. The newly created filter will be listed in the workspace. It will also be available in the Details pane 
when you click the Summary tab of the Dashboard workspace.
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To Create a filter from an MDX Query

• After creating the Dashboard, click the Filter tab in the workspace pane in the center of the screen.

• Click New Filter.

• In the Select a Dashboard Filter Template wizard, select MDX Query, and then click OK.

• Type a filter name in the Name text box (required). 

• Type a description of the filter in the Description text box (not required).

• Click Next.

• Select a data source from the list displayed. If you do not see the data source you want, click Refresh 
to update the list. Click Next.

• Type your MDX query in the box provided. Click Next.

• Select a display method to choose how you want the filter to display on the Dashboard. Click Finish.

• If the filter is successfully created, a confirmation page will display. Click Close.

• The newly created filter will be listed in the workspace. It will also be available in the Details pane 
when you click the Summary tab of the Dashboard workspace.
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To create a filter with a Named Set

1. After creating the Dashboard, click the Filter tab in the workspace pane in the center of the screen.

2. Click New Filter.

3. In the Select a Dashboard Filter Template wizard, select Named Sets, and then click OK.

4. Type a filter name in the Name text box.

5. Type a description of the filter in the Description text box (optional).

6. Select a data source for the filter from the list displayed. If you do not see the data source you need, 
click Refresh to update the list from the server. Click Next. 

7. Select the desired Named Set from the dropdown list. The expression of the selected named set will 
display in read-only format in the box below. Click Next. 

8. Choose how you want the filter to display on the Dashboard: A list, a tree or a multi-tree format. Click 
Finish.

9. If the filter is successfully created, a confirmation page will display. Click Close.

10. The newly created filter will be listed in the workspace pane . It will also be available in the Details 
pane when you click the Summary tab of the Dashboard workspace.
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To create a filter using Time Intelligence members

1. After creating the Dashboard, click the Filter tab in the workspace pane in the center of the screen.

2. Click New Filter.

3. In the Select a Dashboard Filter Template wizard, select Time Intelligence, and then click OK.

4. Type a filter name in the Name text box.

5. Type a description of the filter in the Description text box (optional).

6. Click Next.

7. Click Add Data Source. Select a data source from the list displayed on either the server or workspace 
tab. If you do not see the data source that you need, click Refresh on the Server tab to update the list. 
Click Next.

8. Enter a time formula and a caption.

9. Click Add formula to add additional formula lines (optional).

10. Click Next.

11. Choose how you want the filter to display on the Dashboard: A list, a tree or a multi-tree format. Click 
Finish.

12. If the filter is successfully created, a confirmation page will display. Click Close. 

13. The newly created filter will be listed in the workspace. It will also be available in the Details pane 
when you click the Summary tab of the Dashboard workspace
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To Create a filter using Time Intelligence Post Formula

1. After creating the Dashboard, click the Filter tab in the workspace pane in the center of the screen.

2. Click New Filter.

3. In the Select a Dashboard Filter Template wizard, select Time Intelligence Post Formula, and then click 
OK.

4. Type a filter name in the Name text box.

5. Type a description of the filter in the Description text box (optional).

6. Click Next.

7. Click Add Data Source. Select a data source from the list displayed on either the server or workspace 
tab. If you do not see the data source that you need, click Refresh on the Server tab to update the list. 
Click Next.

8. Enter a time formula and a caption.

9. Click Add formula to add additional formula lines (optional).

10. Click Next.

11. Choose how you want the filter to display on the Dashboard from the Time Intelligence Calendar. Click 
Finish.

12. If the filter is successfully created, a confirmation page will display. Click Close. 

13. The newly created filter will be listed in the workspace. It will also be available in the Details pane 
when you click the Summary tab of the Dashboard workspace.
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To Link Filters to Dashboard Elements

1. On the Workspace Browser pane, double-click the name of the dashboard you want to modify.

2. On the Editor tab, view the items that have been added to the dashboard.

3. From the Details pane, drag a filter to a dashboard zone. Where you put the filter is where it will display on the deployed 
dashboard.

4. On the filter, click the down arrow and select Create Link. The Filter Link Editor will display.

5. On the Link Items tab, select the dashboard item to link to the filter.

6. Click the Link Options tab.

7. From the Dashboard item endpoint box, specify where you want filter values to appear in the linked dashboard item.

8. From the Source Value box, select the value such as Display Value or MemberUniqueName to use the deployed 
dashboard. Source Value options vary by type of filter or report.

9. You must use MemberUniqueName to link to any analytic data source, such as a scorecard, an Analytic Chart or Grid, a 
Pivot Chart or Pivot Table, and so on.

10. (Optional) Click Filter Link Formula if you want to use a custom query. The language you use is dictated by the data 
source. For example, you can use MDX or a TI time formula.

11. Click OK.

To Link more than one Dashboard element to a single filter

1. Follow the steps to link a filter to a dashboard element. 

2. On the next dashboard element for which you want to create a link, click the arrow and select Create Link. 

3. On the Link Items tab, select the column or filter to link to.

4. Click the Link Options tab.

5. From the Dashboard item endpoint box, specify where you want filter values to appear in the linked dashboard item.

6. From the Source Value box, select to use the Display Value or MemberUniqueName on the deployed dashboard. If you 
are linking to an Analytic Chart or Analytic Grid report, you must select MemberUniqueName.

7. (Optional) Click Filter Link Formula if you want to use a custom query. The language you use is dictated by the data 
source. Examples are MDX, SQL, or the Simple Time Period Specification.

8. Click OK.
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To deploy a dashboard to a preview site

1. On the Home tab, click Publish All. This publishes the dashboard to the server.

2. On the Edit tab, click Preview. 

3. In the Deploy Dashboard to Web Pages wizard, select the dashboard that you want to preview, and 
then click Next. 

4. Typically, Dashboard Designer uses the correct preview site location (based on Monitoring Server 
configurations). You can keep the URL that appears or specify a different Web site URL, and then click 
Finish. A Web browser will open and display the dashboard on the preview site.
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To deploy a dashboard to a SharePoint site

1. Publish all of your elements.

2. On the Edit tab, click SharePoint Site. This opens the Deploy a Dashboard to a SharePoint Site wizard.

3. In the Select Dashboard page, select the dashboard that you want to deploy. If the dashboard is not 
listed in the Name column, click Refresh to update the list from the server. When you have selected 
the dashboard, click Next. 

4. In the Specify Location page, the default SharePoint site address appears. You can keep this setting or 
type the full path to a different SharePoint site where you want to deploy the dashboard. This 
automatically populates the Document Library drop-down list.

5. In the Document Library list, select the document library where the dashboard will reside. Click Next.

6. In the Select Layout page, use the drop-down list to select the master page. This master page 
determines the layout for the dashboard when it is deployed. 

7. Click Finish. A Web browser opens to display the dashboard in the SharePoint site.

8. When the Confirmation page is displayed in Dashboard Designer, click Close.
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Scorecards typically display sensitive business information

• It is recommend that you use Secure Sockets Layer (SSL) or some other kind of encryption for any Web 
site that hosts PPS data.

• Without encryption, the data that is transmitted every time a user accesses a PPS view or the PPS Web 
service could be intercepted by unauthorized users. 
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Server Roles
• Permissions for Dashboard Designer are divided into server roles, those which control permissions for 

the entire Monitoring server, and the Dashboard element roles, which control permissions to specific 
dashboard elements.

• Server roles apply to the entire PerformancePoint Monitoring installation and grant system-wide 
access to data and tasks. There are four types of server roles:

Admin: 
• This role provides complete control over the PerformancePoint Server . Users who have permissions to 

this role have access to all dashboard data. They can create, edit, and delete all dashboard elements as 
well as publish dashboards to the server. They also have the ability grant roles to other users. The 
administrators group on the computer that hosts PerformancePoint Server is added to this role 
automatically.

Data Source Manager: 
• This role enables users to create and delete data sources. Users who have permissions for the Data 

Source Manager role also can publish data sources to the PerformancePoint Server

Creator: 
• This role enables users to create KPIs, scorecards, and indicators. Users who have permissions for this 

role can also publish dashboard elements to the PerformancePoint Server . They can also delete 
elements where they have Editor role permissions

Power Reader: 
• This role grants read-only access to all dashboard elements on the PerformancePoint Server , and is 

primarily used for alerts. It enables users to download dashboard elements from the PerformancePoint 
Server .
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Element roles 

• Permissions to elements are assigned on a per-element basis, so roles are specific to each dashboard, 
KPI, scorecard, data source, and indicator. 

Editor 

• This role enables users to edit all data related to the dashboard, KPI, objective, scorecard, data source 
or scorecard to which the permissions apply. When users with the Admin or Data Source Manger roles 
create a scorecard element, they are automatically added to the Editor role for those elements. Users 
that have permissions to the Editor role have all of the access rights of users that belong to the Reader 
role. 

Reader: 

• This role grants read-only access to specific elements. It enables users to download dashboard 
elements from the database on the server and view those objects.
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Preventing direct client connection to the Microsoft PPS data sources helps ensure data 
integrity. 

• The PPS layer includes

–Internet Information Services (IIS)

–Microsoft Windows SharePoint Services

–Microsoft SharePoint Portal Server

–PPS Builder



SUGGESTED SLIDE
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PPS uses the IIS impersonation feature to access resources on behalf of the client 
computer.

• The default configuration is for a client computer to 

–connect to PPS through IIS and Windows SharePoint Services or SharePoint Portal Server

–then for the client computer to request scorecard data



User Pass-Through Authentication

• On each of the Monitoring web sites (PPSMonitoringPreview, PPSWebService, and SharePoint) the 
web.config file contains a property called ConnectionPerUser. Setting this property to True will force 
the application to connect using the authenticated users credentials. If the Monitoring web sites are 
on the same machine as Analysis Services no additional steps are required. If AS is on a separate box 
you will need to configure Kerberos Delegation on the domain and middle tier.

<appSettings>

<add key="Bpm.MonitoringConnectionString" value="Data Source=PPSMADEMO;Initial
Catalog=PPSMonitoring;Integrated Security=True" />

<add key="Bpm.ServerConnectionPerUser" value=“True" />

<add key="Bpm.ElementMemoryCacheTime" value="5" />

<add key="Bpm.EnableAnalyticQueryLogging" value="False" />

<add key="Bpm.UseASCustomData" value="False" />

<add key="Bpm.IndicatorImageCacheTime" value="10" />

<add key="Bpm.DataSourceQueryTimeout" value="300" />

</appSettings>

Module 5: Security

Microsoft Confidential Page: 10



Custom Data

• Use the CustomData field on an Analysis Services connection string. Our application is able to specify 
the domain/username of the account which authenticated to our server as the CustomData of the 
connection string. It is possible to then configure Analysis Services security model to restrict access 
based on the string containing the username provided by our application.

Example

<appSettings>

<add key="Bpm.MonitoringConnectionString" value="Data Source=PPSMADEMO;Initial
Catalog=PPSMonitoring;Integrated Security=True" />

<add key="Bpm.ServerConnectionPerUser" value=“True" />

<add key="Bpm.ElementMemoryCacheTime" value="5" />

<add key="Bpm.EnableAnalyticQueryLogging" value="False" />

<add key="Bpm.UseASCustomData" value=“True" />

<add key="Bpm.IndicatorImageCacheTime" value="10" />

<add key="Bpm.DataSourceQueryTimeout" value="300" />

</appSettings>
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Using Analysis Services 

• Roles with PPS requires you to know the roles that have been defined and that are available in Analysis 
Services. 

• Analysis Services roles are not visible from any part of the Dashboard Designer user interface, and they 
are distinct from PPS Monitor roles. 

• Analysis Services roles can be used in PPS by including them in the connection string when you map a 
key performance indicator (KPI) to a data source. 
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